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Standard cover page is blank for standard users

Issue:

When a Standard user with all the correct permissions uses the Standard cover page feature, it creates a blank page. This does not happen with the Admin user. The issue is not resolved if we give the Standard user the “Customize Application” Admin permission. The issue occurs when using two factor authentication.

Cause:

This is a known Salesforce issue: If an org has a user whose profile has session setting set as ‘High Assurance’, when this user runs an async Apex job to create a PDF attachment, the attachment data shows as null. See this article for more detail: https://issues.salesforce.com/issue/a028c00000qPxndAAC/two-factor-authenticated-user-having-session-setting-set-as-high-assurance-and-async-apex-generated-pdf-attachment-file-content-shows-as-blank

Solution:

The only workaround is to remove the session security level specification from user profile by updating the security level required at login from “High Assurance” to “None”. Go to Profile -> [select the standard user profile] -> Session Settings -> Session Security Level Required at Login -> None. Without this update the user will not be able to create Standard coversheet.